Wheelton - Lost (140/chill)

unsigned forum members' tracks & place for feedback
Forum rules
By using this "Dubs" sub-forum, you acknowledge that you have read, understood and agreed with our terms of use for this site. Click HERE to read them. If you do not agree to our terms of use, you must exit this site immediately. We do not accept any responsibility for the content, submissions, information or links contained herein. Users posting content here, do so completely at their own risk.

Quick Link to Production Forum
Locked
Mitch_dubstepuk
Posts: 435
Joined: Wed Mar 31, 2010 10:17 pm
Location: Stoke-on-Trent, Midlands, UK
Contact:

Wheelton - Lost (140/chill)

Post by Mitch_dubstepuk » Mon Mar 24, 2014 12:00 am

Something new and a bit different from me...not the usual dark bits I produce. Let me know your thoughts :) Enjoy

Soundcloud

User avatar
Soul_Of_Seun
Posts: 561
Joined: Sun Feb 19, 2012 8:48 am
Location: Denver,CO

Re: Wheelton - Lost (140/chill)

Post by Soul_Of_Seun » Mon Mar 24, 2014 6:18 am

Solid intro, I like how it grows and increases in volume. No complaints from me however, the vocal sample saying "have you ever felt.." feels a bit dry. Maybe try some more delay on it? Other than that it's a pretty good effort. Sort of Like Boards of Canada Meets Be-1ne. Good job.
Soundcloud

Mystical

Mindgate
Posts: 28
Joined: Sat Aug 27, 2011 11:16 pm

Re: Wheelton - Lost (140/chill)

Post by Mindgate » Wed Mar 26, 2014 1:27 pm

Love it as always man. I guess I have to go to your cloud and relisten everything (again) :)

Mitch_dubstepuk
Posts: 435
Joined: Wed Mar 31, 2010 10:17 pm
Location: Stoke-on-Trent, Midlands, UK
Contact:

Re: Wheelton - Lost (140/chill)

Post by Mitch_dubstepuk » Sat Mar 29, 2014 12:34 pm

respect for the comments guys!

Locked

Who is online

Users browsing this forum: Bing [Bot] and 33 guests